03 600rr cutting out - 600RR.net
Troubleshooting Having trouble with your bike? Common know issues or trobuleshooting questions here.

 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 12-29-2007, 01:19 PM Thread Starter
 
Join Date: Dec 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy 03 600rr cutting out

03 600 rr ,engine cuts out, stalls ,when i got bike home it cut out , with ignition switched on and engine off the led panel would light up then go blank intermintently, while thebike was stationary....!! HELP
big den is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 01-01-2008, 09:09 PM
 
Join Date: Jun 2007
Posts: 164
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
You probly have a wire causing a short somewhere.That are its a ground.Was the bike dropped or towed anything outta the normal?
R6ixxer is offline  
post #3 of 8 (permalink) Old 01-07-2008, 09:34 AM
Knightslugger
Guest
 
Posts: n/a
check your battery terminal connections.
 
post #4 of 8 (permalink) Old 01-07-2008, 10:21 AM
Back in the Day
 
Moeman's Avatar
 
Join Date: Jul 2003
Location: Central Florida
Posts: 51,143
Images: 665
Thanks: 2,026
Thanked 2,544 Times in 2,156 Posts
Feedback Score: 148 reviews
Led panel = cluster ? If yes
Then check the cluster's plug it might have gotten loose



If it doesn't challange you it won't change you
Only two ways to live life. One is as though nothing is a miracle. The other is as though everything is a miracle.
Moeman is offline  
post #5 of 8 (permalink) Old 01-07-2008, 03:46 PM Thread Starter
 
Join Date: Dec 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
following morning i took the battery out to check it put it back in and led panel lit up and away we went...!!!! :icon_lol::icon_lol::icon_lol: still a bit worried about travelling to far. thanxs for info
big den is offline  
post #6 of 8 (permalink) Old 01-08-2008, 12:33 AM
Pocketbike Racer
 
WTFGO's Avatar
 
Join Date: Sep 2007
Location: Ontario, CA
Posts: 400
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 3 reviews
I had a very similar problem. It was the battery. Bought a new one and all those problems went away.
WTFGO is offline  
post #7 of 8 (permalink) Old 01-08-2008, 01:40 PM Thread Starter
 
Join Date: Dec 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
been reading about some probs concerning battery's and charging issues on rr and will get it checked, once again mega thanx, magic web site, will keep ye all posted :icon_salu:icon_salu:icon_salu
big den is offline  
post #8 of 8 (permalink) Old 01-10-2008, 02:18 AM
 
Join Date: Dec 2006
Posts: 125
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
there have been rectifier issues on the 03-04's. maybe that could be the problem.
marinelzen is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 600RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome